Unable to book equipment
Incident Report for CHEQROOM
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 07:17 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2020 - 07:04 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 21, 2020 - 06:33 EDT
Investigating
We are currently investigating an issue that prevents you from adding items to a booking
Posted Apr 21, 2020 - 03:34 EDT
This incident affected: Web application and Mobile apps.