Degraded Performance

Incident Report for Cheqroom

Resolved

This incident has been resolved
Posted Jun 11, 2025 - 14:00 EDT

Identified

We have identified degraded performance throughout the web application, particularly impacting reservations and item detail.
Posted Jun 11, 2025 - 13:39 EDT
This incident affected: Web application.