Web application degraded performance
Incident Report for Cheqroom
Resolved
Update: Our team has resolved the issue and performance in Cheqroom has been restored. We apologize for any inconvenience this may have caused and thank you for your patience. If you continue to experience any issues, please reach out to our support team for assistance.
Posted Jan 18, 2023 - 08:33 EST
Investigating
We are currently experiencing degraded performance in Cheqroom. Our team is working diligently to identify and resolve the issue. We apologize for any inconvenience this may cause and appreciate your patience as we work to restore full functionality. We will provide updates as more information becomes available.
Posted Jan 18, 2023 - 05:06 EST
This incident affected: Web application.