Some customers experiencing issues when making a reservation
Incident Report for Cheqroom
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 05:42 EDT
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Jun 22, 2023 - 03:25 EDT
Investigating
We are aware some customers are experiencing issues when making a reservation. We’re currently investigating the issue and working hard to resolve it.
Posted Jun 21, 2023 - 17:59 EDT
This incident affected: Web application.