Access issues to CHEQROOM
Incident Report for CHEQROOM
Resolved
Service restored.

Sorry for that folks, reach out via help.cheqroom.com if you have any questions or concerns!
Posted Apr 11, 2019 - 15:17 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2019 - 15:05 CEST
Investigating
We are currently investigating this issue
Posted Apr 11, 2019 - 15:02 CEST
This incident affected: Web application.