Contact Exports having degraded performance
Incident Report for CHEQROOM
Resolved
This incident has been resolved 🤓
Posted Jul 03, 2018 - 15:29 CEST
Investigating
We are investigating an issue with Contact Exports having degraded performance. We'll send a notification when everything is back to normal.
Posted Jul 03, 2018 - 15:10 CEST
This incident affected: Email delivery.