Degraded performance
Incident Report for Cheqroom
Resolved
This incident has been resolved.
Posted Apr 25, 2022 - 06:57 EDT
Monitoring
Performance seems to have stabilized, we continue monitoring for any issues.
Posted Apr 25, 2022 - 06:15 EDT
Investigating
We're currently experiencing an elevated level of performance issues and request timeouts.

We're investigating the issue.
Posted Apr 25, 2022 - 04:57 EDT
This incident affected: Web application and Mobile apps.